订阅本站
收藏本站
微博分享
QQ空间分享

python3.6安装

lilin 分类:环境搭建 时间:2019/11/24 23:01:09 评论: 加入收藏

ubuntu16 默认安装python2.7,python3.5,这两个版本尽量不要去动,因为有些系统依赖于这两个版本
sudo add-apt-repository ppa:jonathonf/python-3.6
sudo apt-get update
sudo apt-get install python3.6
各版本使用命令对应关系python >>python2.7 python3>>python3.5 python3.6 >>python3.6
默认python2和python3都没有安装对应的pip
sudo apt-get install python3-pip
sudo pip3 install --upgrade pip
sudo apt-get install python-pip
sudo pip install --upgrade pip

 
 
image.png

sudo apt-get install python-virtualenv
这里说一下,其实执行apt install python-virtualenv命令的同时会执行apt install python3-virtualenv,所以只需执行apt install python-virtualenv,即可安装python-virtualenv和python3-virtualenv。
sudo pip3 install virtualenvwrapper
配置virtualwrapper的环境变量
sudo vim ~/.bashrc
在配置文件最后添加如下内容
export VIRTUALENVWRAPPER_PYTHON=/usr/bin/python3

  • 虚拟环境存储的目录

export WORKON_HOME=$HOME/.virtualenvs
source /usr/local/bin/virtualenvwrapper.sh

(问题???为什么指定python3了默认虚拟环境安装还是python2呢,有时间研究一下)

使配置文件生效
source ~/.bashrc
创建虚拟环境
mkvirtualenv <环境名>
默认使用的python2.7创建的
指定python版本创建虚拟环境
mkvirtualenv --python=<pyhton3.6> <环境名>
进入虚拟环境
workon <name>
退出虚拟环境
deactivate
删除虚拟环境
直接删除 ~/.virtualenvs/下对应文件夹即可



 

TAG:

文章评论

留言与评论(共有 0 条评论)
   
验证码: