订阅本站
收藏本站
微博分享
QQ空间分享

GNU C Library xdr_bytes/xdr_string函数拒绝服务漏洞(CVE-2017-8804)

alen 分类:安全维护 时间:2018/11/20 00:00:00 评论: 加入收藏
GNU C Library xdr_bytes/xdr_string函数拒绝服务漏洞(CVE-2017-8804)


发布日期:2017-05-03
更新日期:2017-05-08

受影响系统:

GNU glibc 2.25

描述:


CVE(CAN) ID: CVE-2017-8804

glibc是GNU发布的libc库,即c运行库。

GNU C Library (glibc/libc6) 2.25版本,函数xdr_bytes、xdr_string未正确处理缓冲区反序列化失败。可使远程攻击者通过向端口111发送构造的UDP包,造成拒绝服务。

<*来源:vendor
  *>

建议:


厂商补丁:

GNU
---
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载

http://www.openwall.com/lists/oss-security/2017/05/05/2
https://bugzilla.suse.com/show_bug.cgi?id=1037559#c7
https://sourceware.org/bugzilla/show_bug.cgi?id=21461
https://sourceware.org/ml/libc-alpha/2017-05/msg00105.html

本文永久更新链接地址:http://www.linuxidc.com/Linux/2017-05/143559.htm

TAG:

文章评论

留言与评论(共有 0 条评论)
   
验证码: