订阅本站
收藏本站
微博分享
QQ空间分享

Linux kernel crypto_skcipher_init_tfm函数拒绝服务漏洞(CVE-2017-9211)

alen 分类:安全维护 时间:2018/11/20 00:00:00 评论: 加入收藏
Linux kernel crypto_skcipher_init_tfm函数拒绝服务漏洞(CVE-2017-9211)


发布日期:2017-05-18
更新日期:2017-05-24

受影响系统:

Linux kernel < 4.11.2

描述:


CVE(CAN) ID: CVE-2017-9211

Linux Kernel是Linux操作系统的内核。

Linux kernel < 4.11.2版本,crypto/skcipher.c/crypto_skcipher_init_tfm函数所依靠的setkey函数缺少密钥大小检查,可使本地用户通过构造的应用,造成拒绝服务。

<*来源:vendor
  *>

建议:


厂商补丁:

Linux
-----
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载

http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=9933e113c2e87a9f46a40fde8dafbf801dca1ab9
https://github.com/torvalds/linux/commit/9933e113c2e87a9f46a40fde8dafbf801dca1ab9
https://patchwork.kernel.org/patch/9718933/

本文永久更新链接地址:http://www.linuxidc.com/Linux/2017-05/144180.htm

TAG:

文章评论

留言与评论(共有 0 条评论)
   
验证码: