订阅本站
收藏本站
微博分享
QQ空间分享

Foxit Reader XFA setInterval释放后重利用代码执行漏洞(CVE-2018-17628)

alen 分类:安全维护 时间:2018/11/20 00:00:00 评论: 加入收藏
Foxit Reader XFA setInterval释放后重利用代码执行漏洞(CVE-2018-17628)


发布日期:2018-10-11
更新日期:2018-10-16

受影响系统:

Foxit Phantom PDF <= 9.2.0.9297
Foxit Reader <= 9.2.0.9297

描述:


CVE(CAN) ID: CVE-2018-17628

Foxit Reader for Windows是一款基于Windows平台的PDF文档阅读器。Foxit PhantomPDF for Windows是它的商业版。

Windows平台上Foxit Reader 9.2.0.9297及之前版本和Foxit PhantomPDF 9.2.0.9297及之前版本,XFA setInterval方法存在释放后重用漏洞,该漏洞源于程序在对对象执行操作之前,没有验证该对象是否存在。远程攻击者可借助特制的页面或文件利用该漏洞在当前进程的上下文中执行代码。

<*来源:Esteban Ruiz (mr_me)
 
  链接:https://www.foxitsoftware.com/support/security-bulletins.php
*>

建议:


厂商补丁:

Foxit
-----
Foxit已经为此发布了一个安全公告(Security bulletins)以及相应补丁:
Security bulletins:Security updates available in Foxit Reader 9.3 and Foxit PhantomPDF 9.3
链接:https://www.foxitsoftware.com/support/security-bulletins.php

Linux公社的RSS地址:https://www.linuxidc.com/rssFeed.aspx

本文永久更新链接地址:https://www.linuxidc.com/Linux/2018-10/154853.htm

TAG:

文章评论

留言与评论(共有 0 条评论)
   
验证码: