订阅本站
收藏本站
微博分享
QQ空间分享

Proface GP-Pro EX栈缓冲区溢出远程代码执行漏洞

alen 分类:安全维护 评论: 加入收藏
Proface GP-Pro EX栈缓冲区溢出远程代码执行漏洞


发布日期:2016-01-08
更新日期:2016-01-11

受影响系统:

Proface GP-Pro EX

描述:


Proface GP-Pro EX是多个平台上使用的人机接口HMI软件

Proface GP-Pro EX在BeginPreRead处理中存在安全漏洞。在处理畸形的0x7f77类型字段时,攻击者利用此漏洞可造成栈缓冲区溢出,在当前进程上下文中执行任意代码。

<*来源:Steven Seeley (seeleymagic@hotmail.com)
 
  链接:http://www.zerodayinitiative.com/advisories/ZDI-16-003/
*>

建议:


厂商补丁:

Proface
-------
目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:

http://www.profaceamerica.com/en-US/content/gp-pro-ex-hmi-software

本文永久更新链接地址:http://www.linuxidc.com/Linux/2016-01/127302.htm

TAG:

文章评论

留言与评论(共有 0 条评论)
   
验证码: