订阅本站
收藏本站
微博分享
QQ空间分享

libpng 'pngwutil.c' 远程代码执行漏洞(CVE-2015-8540)

alen 分类:安全维护 时间:2018/11/20 00:00:00 评论: 加入收藏
libpng 'pngwutil.c' 远程代码执行漏洞(CVE-2015-8540)


发布日期:2016-04-12
更新日期:2016-04-15

受影响系统:

libpng libpng 1.5.x < 1.5.26
libpng libpng 1.4.x < 1.4.19
libpng libpng 1.3.x
libpng libpng 1.2.x < 1.2.56
libpng libpng 1.1.x
libpng libpng 1.0.x < 1.0.66
libpng libpng 0.90 <= 0.99

描述:


CVE(CAN) ID: CVE-2015-8540

libpng是适用于多种应用程序的PNG图形解析函数库。

libpng某些版本,pngwutil.c/png_check_keyword函数存在整数溢出漏洞。远程攻击者通过触发越界读,可执行任意代码。

<*来源:xiaoqixue_1
  *>

建议:


厂商补丁:

libpng
------
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载

http://sourceforge.net/projects/libpng/files/libpng10/1.0.66/
http://sourceforge.net/p/libpng/bugs/244/
http://sourceforge.net/projects/libpng/files/libpng12/1.2.56/
http://sourceforge.net/projects/libpng/files/libpng14/1.4.19/

本文永久更新链接地址:http://www.linuxidc.com/Linux/2016-04/130319.htm

TAG:

文章评论

留言与评论(共有 0 条评论)
   
验证码: