订阅本站
收藏本站
微博分享
QQ空间分享

PHP escapeshellarg 函数任意命令执行漏洞(CVE-2015-4642)

alen 分类:安全维护 时间:2018/11/20 00:00:00 浏览: 评论: 加入收藏
PHP escapeshellarg 函数任意命令执行漏洞(CVE-2015-4642)


发布日期:2016-05-16
更新日期:2016-05-21

受影响系统:

PHP PHP < 5.4.42
PHP PHP 5.6.x < 5.6.10
PHP PHP 5.5.x < 5.5.26

描述:


CVE(CAN) ID: CVE-2015-4642

PHP是广泛使用的通用目的脚本语言,特别适合于Web开发,可嵌入到HTML中。

PHP < 5.4.42, 5.5.x < 5.5.26, 5.6.x < 5.6.10版本,ext/standard/exec.c /escapeshellarg函数存在安全漏洞,远程攻击者利用此漏洞可执行命令

<*来源:PHP
 
  *>

建议:


厂商补丁:

PHP
---
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载

http://php.net/ChangeLog-5.php
http://php.net/ChangeLog-7.php

本文永久更新链接地址:http://www.linuxidc.com/Linux/2016-05/131617.htm

TAG:

文章评论

留言与评论(共有 0 条评论)
   
验证码: