订阅本站
收藏本站
微博分享
QQ空间分享

PHP locale_accept_from_http拒绝服务漏洞(CVE-2016-6294)

alen 分类:安全维护 评论: 加入收藏
PHP locale_accept_from_http拒绝服务漏洞(CVE-2016-6294)


发布日期:2016-07-25
更新日期:2016-07-26

受影响系统:

PHP PHP < 5.5.38
PHP PHP 7.x < 7.0.9
PHP PHP 5.6.x < 5.6.24

描述:


CVE(CAN) ID: CVE-2016-6294

PHP是广泛使用的通用目的脚本语言,特别适合于Web开发,可嵌入到HTML中。

PHP < 5.5.38, 5.6.x < 5.6.24, 7.x < 7.0.9,ext/intl/locale/locale_methods.c/locale_accept_from_http函数未正确限制调用ICU uloc_acceptLanguageFromHTTP函数,远程攻击者可造成拒绝服务(越界读)。

<*来源:PHP
  *>

建议:


厂商补丁:

PHP
---
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载

http://git.php.net/?p=php-src.git;a=commit;h=cab1c3b3708eead315e033359d07049b23b147a3
https://bugs.php.net/72479
http://php.net/ChangeLog-5.php
http://php.net/ChangeLog-7.php

本文永久更新链接地址:http://www.linuxidc.com/Linux/2016-07/133559.htm

TAG:

文章评论

留言与评论(共有 0 条评论)
   
验证码: