订阅本站
收藏本站
微博分享
QQ空间分享

OpenJPEG 堆缓冲区溢出漏洞(CVE-2016-9118)

alen 分类:安全维护 时间:2018/11/20 00:00:00 浏览: 评论: 加入收藏
OpenJPEG 堆缓冲区溢出漏洞(CVE-2016-9118)


发布日期:2016-10-30
更新日期:2016-10-31

受影响系统:

OpenJPEG OpenJPEG 2.1.2

描述:


CVE(CAN) ID: CVE-2016-9118

OpenJPEG库是用C语言编写的开源JPEG 2000编码解码器。

OpenJPEG 2.1.2在convert.c:1719 pnmtoimage函数中存在堆缓冲区溢出漏洞,可导致任意代码执行或拒绝服务。

<*来源:OpenJPEG
  *>

建议:


厂商补丁:

OpenJPEG
--------
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载

http://www.openjpeg.org/

https://github.com/uclouvain/openjpeg/issues/861

本文永久更新链接地址:http://www.linuxidc.com/Linux/2016-10/136583.htm

TAG:

文章评论

留言与评论(共有 0 条评论)
   
验证码: