订阅本站
收藏本站
微博分享
QQ空间分享

Piwigo 远程文件包含漏洞(CVE-2016-10105)

alen 分类:安全维护 时间:2018/11/20 00:00:00 评论: 加入收藏
Piwigo 远程文件包含漏洞(CVE-2016-10105)


发布日期:2017-01-03
更新日期:2017-01-04

受影响系统:

Piwigo Piwigo < 2.8.3

描述:


BUGTRAQ  ID: 95202
CVE(CAN) ID: CVE-2016-10105

Piwigo是用PHP编写的相册脚本。

Piwigo 2.8.3之前版本,admin/plugin.php未验证用于包含文件的sections变量,若其中含有“..”序列,可导致信息泄露及代码执行。

<*来源:Shinkurt
  *>

建议:


厂商补丁:

Piwigo
------
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载

https://github.com/Piwigo/Piwigo/commit/4b33a0fd199fd445b15a49927ea6a9a153e3877d

https://github.com/Piwigo/Piwigo/issues/573#issuecomment-267974558

本文永久更新链接地址:http://www.linuxidc.com/Linux/2017-01/139192.htm

TAG:

文章评论

留言与评论(共有 0 条评论)
   
验证码: