订阅本站
收藏本站
微博分享
QQ空间分享

Linux kernel snd_pcm_period_elapsed函数拒绝服务漏洞(CVE-2016-9794)

alen 分类:安全维护 时间:2018/11/20 00:00:00 评论: 加入收藏
Linux kernel snd_pcm_period_elapsed函数拒绝服务漏洞(CVE-2016-9794)


发布日期:2016-12-28
更新日期:2016-12-29

受影响系统:

Linux kernel < 4.7

描述:


CVE(CAN) ID: CVE-2016-9794

Linux Kernel是Linux操作系统的内核。

Linux kernel < 4.7版本的ALSA子系统中,sound/core/pcm_lib.c/snd_pcm_period_elapsed函数存在竞争条件漏洞,本地用户通过构造的SNDRV_PCM_TRIGGER_START命令,可造成拒绝服务(释放后重利用)。

<*来源:Andrej Nemec
  *>

建议:


厂商补丁:

Linux
-----
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载

https://bugzilla.redhat.com/show_bug.cgi?id=1401494
https://github.com/torvalds/linux/commit/3aa02cb664c5fb1042958c8d1aa8c35055a2ebc4
http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=3aa02cb664c5fb1042958c8d1aa8c35055a2ebc4
https://patchwork.kernel.org/patch/8752621/

本文永久更新链接地址:http://www.linuxidc.com/Linux/2016-12/138966.htm

TAG:

文章评论

留言与评论(共有 0 条评论)
   
验证码: