订阅本站
收藏本站
微博分享
QQ空间分享

cURL/libcURL缓冲区溢出漏洞(CVE-2016-9586)

alen 分类:安全维护 时间:2018/11/20 00:00:00 评论: 加入收藏
cURL/libcURL缓冲区溢出漏洞(CVE-2016-9586)


发布日期:2016-12-21
更新日期:2017-03-29

受影响系统:

cURL cURL 7.1 <= 7.51.0

不受影响系统:

cURL cURL >= 7.52.0

描述:


BUGTRAQ  ID: 95019
CVE(CAN) ID: CVE-2016-9586

libcURL是命令行传输文件工具

cURL/libcURL 7.1 <= 7.51.0版本,printf()函数进行大量的浮点输出时,会触发缓冲区溢出。可使攻击者在受影响应用上下文中执行任意代码。

<*来源:Daniel Stenberg (daniel@haxx.se)
 
  链接:https://curl.haxx.se/docs/adv_20161221A.html
*>

建议:


厂商补丁:

cURL
----
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载

https://curl.haxx.se/CVE-2016-9586.patch

本文永久更新链接地址:http://www.linuxidc.com/Linux/2017-03/142334.htm

TAG:

文章评论

留言与评论(共有 0 条评论)
   
验证码: