订阅本站
收藏本站
微博分享
QQ空间分享

libssh 类型混淆漏洞(CVE-2016-0739)

alen 分类:安全维护 时间:2018/11/20 00:00:00 评论: 加入收藏
libssh 类型混淆漏洞(CVE-2016-0739)


发布日期:2016-04-04
更新日期:2016-04-05

受影响系统:

libssh libssh

描述:


CVE(CAN) ID: CVE-2016-0739

libssh 是一个用以访问SSH服务的C语言开发包,通过它可以执行远程命令、文件传输,同时为远程的程序提供安全的传输通道。

libssh生成diffie-hellman-group1/diffie-hellman-group14密钥交换方法的临时密码中存在类型混淆漏洞,可造成SSHv2 Diffie-Hellman握手使用不安全的随机参数。

<*来源:Aris Adamantiadis
  *>

建议:


厂商补丁:

libssh
------
目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:

www.libssh.org

本文永久更新链接地址:http://www.linuxidc.com/Linux/2016-04/129866.htm

TAG:

文章评论

留言与评论(共有 0 条评论)
   
验证码: