订阅本站
收藏本站
微博分享
QQ空间分享

Apache HTTP Server HTTP_PROXY环境变量安全漏洞(CVE-2016-5387)

alen 分类:安全维护 时间:2018/11/20 00:00:00 评论: 加入收藏
Apache HTTP Server HTTP_PROXY环境变量安全漏洞(CVE-2016-5387)


发布日期:2016-07-17
更新日期:2016-07-19

受影响系统:

Apache Group HTTP Server < 2.4.23

描述:


CVE(CAN) ID: CVE-2016-5387

Apache HTTP Server是Apache软件基金会的一个开放源代码的网页服务器

Apache HTTP Server < 2.4.23版本,RFC 3875 section 4.1.18存在命名空间冲突,HTTP_PROXY环境变量未能过滤构造的客户端数据。远程攻击者构造HTTP请求的Proxy标头,可将应用的HTTP数据流重定向到任意代理服务器

<*来源:Dominic Scheirlinck
        Scott Geary
  *>

建议:


厂商补丁:

Apache Group
------------
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载

http://httpd.apache.org/

参考:
https://www.apache.org/security/asf-httpoxy-response.txt
http://www.kb.cert.org/vuls/id/797896
https://httpoxy.org/

Ubuntu Server 14.04 安装Web服务器(Linux+Apache+MySQL+PHP)  http://www.linuxidc.com/Linux/2015-06/119061.htm

Linux下安装配置PHP环境(Apache2)  http://www.linuxidc.com/Linux/2015-05/118062.htm

Linux下 Apache服务器配置  http://www.linuxidc.com/Linux/2016-06/132025.htm

Ubuntu 13.04 安装 LAMP/Vsftpd/Webmin/phpMyAdmin 服务及设置 http://www.linuxidc.com/Linux/2013-06/86250.htm

CentOS 5.9下编译安装LAMP(Apache 2.2.44+MySQL 5.6.10+PHP 5.4.12) http://www.linuxidc.com/Linux/2013-03/80333p3.htm

RedHat 5.4下Web服务器架构之源码构建LAMP环境及应用PHPWind http://www.linuxidc.com/Linux/2012-10/72484p2.htm

Linux下Apache虚拟主机的配置  http://www.linuxidc.com/Linux/2016-04/130381.htm

Apache 的详细介绍:请点这里
Apache 的下载地址:请点这里

本文永久更新链接地址:http://www.linuxidc.com/Linux/2016-07/133342.htm

TAG:

文章评论

留言与评论(共有 0 条评论)
   
验证码: