订阅本站
收藏本站
微博分享
QQ空间分享

Apache Tomcat HTTP_PROXY环境变量安全漏洞(CVE-2016-5388)

alen 分类:安全维护 时间:2018/11/20 00:00:00 评论: 加入收藏
Apache Tomcat HTTP_PROXY环境变量安全漏洞(CVE-2016-5388)


发布日期:2016-07-17
更新日期:2016-07-19

受影响系统:

Apache Group Tomcat < 8.5.4

描述:


CVE(CAN) ID: CVE-2016-5388

Apache Tomcat是一个流行的开源JSP应用服务器程序。

Apache Tomcat < 8.5.4版本启用CGI Servlet时,RFC 3875 section 4.1.18存在命名空间冲突,HTTP_PROXY环境变量未能过滤构造的客户端数据。远程攻击者构造HTTP请求的Proxy标头,可将应用的HTTP数据流重定向到任意代理服务器

<*来源:Dominic Scheirlinck
        Scott Geary
  *>

建议:


厂商补丁:

Apache Group
------------
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载

http://httpd.apache.org/

参考:
https://www.apache.org/security/asf-httpoxy-response.txt
http://www.kb.cert.org/vuls/id/797896
https://httpoxy.org/

更多Tomcat相关教程见以下内容

CentOS 6.6下安装配置Tomcat环境  http://www.linuxidc.com/Linux/2015-08/122234.htm

RedHat Linux 5.5安装JDK+Tomcat并部署Java项目  http://www.linuxidc.com/Linux/2015-02/113528.htm 

Tomcat权威指南(第二版)(中英高清PDF版+带书签)  http://www.linuxidc.com/Linux/2015-02/113062.htm 

Tomcat 安全配置与性能优化 http://www.linuxidc.com/Linux/2015-02/113060.htm 

Linux下使用Xshell查看Tomcat实时日志中文乱码解决方案 http://www.linuxidc.com/Linux/2015-01/112395.htm 

CentOS 64-bit下安装JDK和Tomcat并设置Tomcat开机启动操作步骤 http://www.linuxidc.com/Linux/2015-01/111485.htm 

CentOS 6.5下安装Tomcat  http://www.linuxidc.com/Linux/2015-01/111415.htm 

Tomcat 的详细介绍:请点这里
Tomcat 的下载地址:请点这里

本文永久更新链接地址:http://www.linuxidc.com/Linux/2016-07/133341.htm

TAG:

文章评论

留言与评论(共有 0 条评论)
   
验证码: